Hd44780 Issue

Oct 2, 2012 at 12:36 AM

When I to run the Hd44780Lcd sample all I get is a blinking cursor at the first position.

I've tried with it with two different Netduinos running 4.1 and a Netduino+ running 4.2.  I've also tried creating my own project and importing the projects/references and everything builds and deploys ok but no text is shown.

Triple checked the wiring as in the example.

Coordinator
Dec 3, 2012 at 11:21 AM

Sorry for the late reply, I rarely look at the discussions tab here ;)

What type of LCD did you use? I have another library I could recommend; http://microliquidcrystal.codeplex.com which may work?

Jul 7, 2013 at 10:05 AM
Not working with N+2. Copied example exactly? 4.2.2? Nothing appears.
Coordinator
Jul 7, 2013 at 12:23 PM
Not working is not something I can do much with.

Do you get an error? What result do you get? How are things connected? What type of LCD did you use?
Jul 8, 2013 at 11:08 PM
Sorry mate I jumped the gun. Had a few other issue’s I couldn’t account for and the under side of the bread board was a corroded and damaged. I’ve got to be more careful with coffee.
Grant,
From: Garrcomm
Sent: ‎Sunday‎, ‎7‎ ‎July‎ ‎2013 ‎9‎:‎23‎ ‎PM
To: [email removed]

From: Garrcomm

Not working is not something I can do much with.

Do you get an error? What result do you get? How are things connected? What type of LCD did you use?
Jul 25, 2013 at 5:04 PM
Edited Jul 25, 2013 at 5:08 PM
xrstokes - I found I had a similar issue with N+2. I stepped through the Hd44780Lcd class and the expected message displayed. I added a Thread.Sleep(1) before this._UpdateDisplayControl(); in _Initialization() and it seems to work every time now.
Coordinator
Jun 21, 2014 at 4:13 PM
Hi sixfortyfour,

If a milisecond helps in some cases, I just have to add it. It's only at initialisation anyways. Thanks for your fix, I've applied it in the toolbox!